16.9. Keyboard Shortcuts

On Mac OS X modifier key is cmd, on other platforms it is Ctrl.

File Menu

FunctionContextKeyboard Shortcut
New ModelAllModifier+N
Open ModelAllModifier+O
Open SQL ScriptSQL EditorModifier+Shift+O
Close TabAllModifier+W
Save ModelModelModifier+S
Save ScriptSQL EditorModifier+S
Save Model AsModelModifier+Shift+S
Save Script AsSQL EditorModifier+Shift+S
Forward Engineer SQL CREATE ScriptModelModifier+Shift+G
Forward Engineer SQL ALTER ScriptModelModifier+Alt+Y
Synchronize With SQL CREATE ScriptModelModifier+Shift+Y
PrintEER Diagram mode onlyModifier+P
ExitAllModifer+Q

Edit Menu

FunctionContextKeyboard Shortcut
UndoModel, EER DiagramModifier+Z
RedoModel, EER DiagramModifier+Y, Modifier+Shift+Z (Mac OS X)
CutAllModifier+X
CopyAllModifier+C
PasteAllModifier+V
DeleteAllModifier+Delete, Command+BackSpace (Mac OS X)
Edit SelectedModel, EER DiagramModifier+E
Edit Selected in New WindowModel, EER DiagramModifier+Shift+E
Select AllEER DiagramModifier+A
FindAllModifier+F
Find AdvancedAllModifier+Alternate+F
Find NextAllF3
Find PreviousAllShift+F3
Search and ReplaceAllModifier+Shift+F

View Menu

FunctionContextKeyboard Shortcut
Output WindowAllModifier+F2, Modifier+Option+2 (Mac OS X)
Set Marker nEER DiagramModifier+Shift+n (n is integer 1..9)
Go to Marker nEER DiagramModifier+n (n is integer 1..9)

Arrange Menu

FunctionContextKeyboard Shortcut
Bring to FrontEER DiagramModifier+Shift+F
Send to BackEER DiagramModifier+Shift+B

Model Menu

FunctionContextKeyboard Shortcut
Add DiagramModel, EER DiagramModifier+T
Validate AllModel, EER DiagramModifier+Alt+V
Validate All (MySQL)Model, EER DiagramModifier+Alt+B
Model OptionsModel, EER DiagramCommand+Alternate+, (Shorcut only available on Mac OS X)

Query Menu

FunctionContextKeyboard Shortcut
Execute statementSQL EditorModifier+Return
Execute statementsSQL EditorModifier+Shift+Return
New TabSQL EditorModifier+T

Database Menu

FunctionContextKeyboard Shortcut
Query DatabaseAllModifier+U
Reverse EngineerModel, EER DiagramModifier+R
Forward EngineerModel, EER DiagramModifier+G
Synchronize ModelModel, EER DiagramModifier+Y

Scripting menu

FunctionContextKeyboard Shortcut
Scripting ShellAllModifier+F3, Modifier+Option+3 (on Mac OS X)
Run Workbench Script FileAllModifier+Shift+R

Help Menu

FunctionContextKeyboard Shortcut
Help IndexAllF1, Command+Option+question (on Mac OS X)

EER Diagram Mode

In the EER Diagram view, there are a number of other keyboard shortcuts available.

FunctionKeyboard Shortcut
Selection toolEscape
Hand toolH
Delete toolD
Layer toolL
Note toolN
Image toolI
Table toolT
View toolV
Routine Group toolG
Non-Identfying Relationship 1:11
Non-Identfying Relationship 1:n2
Identifying Relationship 1:13
Identifying Relationship 1:n4
Identifying Relationship n:m5
Relationship Using Existing Columns6
Copyright © 2010-2020 Platon Technologies, s.r.o.           Home | Man pages | tLDP | Documents | Utilities | About
Design by styleshout